AbleCommerce 7.0 webshop and Authorize.Net gateway update

Questions about how to use the forum and suggestions for new forum topics.


** HOW TO POST HTML CODE SAMPLES.
Post Reply
BlackIce
Ensign (ENS)
Ensign (ENS)
Posts: 11
Joined: Mon Aug 31, 2015 1:16 am

AbleCommerce 7.0 webshop and Authorize.Net gateway update

Post by BlackIce » Mon Aug 31, 2015 6:15 am

We use AbleCommerce 7.0 webshop engine and for the payments we use the Authorize.Net gateway.

Authorize.Net will perform some technical updates and we would like to know that our AbleCommerce 7.0 webshop will work correctly after Authorize.Net releases the technical updates.

The technical updates of Authorize.Net will be the following:
- On September 21, 2015, of Authorize.Net are upgrading api.authorize.net to new security certificates, which are signed using Security Hash Algorithm 2 (SHA-2) and 2048-bit signatures.
- In October of this year, due to system updates, it will be possible to receive Authorize.Net IDs (Transaction ID, Batch ID, etc.) that are not in sequential order. The limits of any Authorize.Net ID field should be no less than 20 characters.
- By June 30, 2016. TLS 1.0 will be disabled.

The exact detail can be found in the following link:
http://app.payment.authorize.net/e/es.a ... 864f3487f8

Will these changes cause any problem in AbleCommerce 7.0 webshops or these changes doesn’t affects the working of AbleCommerce 7.0 webshops?

The component versions what we use are the followings:
AbleCommerce 7.0
PLATFORM: ASP.NET
VERSION: 7.0
BUILD: 10125

AjaxControlToolkit: 1.0.10301.0
CommerceBuilder: 7.0.10110.0
CommerceBuilder.AuthorizeNet: 7.0.9764.0
CommerceBuilder.CanadaPost: 7.0.0.0
CommerceBuilder.CCH: 7.0.0.0
CommerceBuilder.Configuration: 7.0.10102.0
CommerceBuilder.CyberSource: 7.0.9764.0
CommerceBuilder.DataClient.Api: 1.0.0.21
CommerceBuilder.DataClient.Csv: 1.0.0.0
CommerceBuilder.DHL: 7.0.8825.0
CommerceBuilder.ECB: 7.0.0.0
CommerceBuilder.FedEx: 7.0.9725.0
CommerceBuilder.FRBNY: 7.0.0.0
CommerceBuilder.GoogleCheckout: 7.0.10052.0
CommerceBuilder.InternetSecure: 7.0.9764.0
CommerceBuilder.LinkPoint: 7.0.9764.0
CommerceBuilder.Paradata: 7.0.9764.0
CommerceBuilder.PayFlowPro: 7.0.10061.0
CommerceBuilder.PayJunction: 7.0.9764.0
CommerceBuilder.PayPal: 7.0.10071.0
CommerceBuilder.Services: 7.0.9733.0
CommerceBuilder.SkipJack: 7.0.9764.0
CommerceBuilder.UPS: 7.0.10041.0
CommerceBuilder.USPS: 7.0.9728.0
CommerceBuilder.Web: 7.0.9777.0
ComponentArt.Web.UI: 2007.1.1566.3
CyberSource.Base: 2.0.0.0
CyberSource.Clients: 5.0.2.0
CyberSource.Clients.XmlSerializers: 5.0.2.0
CyberSource.WSSecurity: 2.0.0.0
CybsWSSecurityIOP: 1.0.0.0
edtFTPnet: 1.2.4.0
FredCK.FCKeditorV2: 2.5.2912.21007
ICSharpCode.SharpZipLib: 0.85.1.271
Interop.eLicenseLib: 1.0.0.0
LinkPointTransaction: 1.0.1797.29766
log4net: 1.2.10.0
Microsoft.Practices.EnterpriseLibrary.Common: 2.0.0.0
Microsoft.Practices.EnterpriseLibrary.Data: 2.0.0.0
Microsoft.Practices.ObjectBuilder: 1.0.51205.0
Microsoft.Web.Preview: 1.2.61025.0
NVelocity: 7.0.8530.0
PaygatewayNET: 3.0.0.0
paypal_base: 4.2.1.0
PFProCOMLib: 1.0.0.0
PFProdotNET: 0.0.0.0
SerialProvider: 1.0.0.0
UpgradeSerialProvider: 1.0.0.0
Validators: 1.0.0.0
WebChart: 1.1.1.6
wwHoverPanel: 1.85.0.0

User avatar
Katie
AbleCommerce Admin
AbleCommerce Admin
Posts: 2628
Joined: Tue Dec 02, 2003 1:54 am
Contact:

Re: AbleCommerce 7.0 webshop and Authorize.Net gateway update

Post by Katie » Tue Sep 01, 2015 8:25 am

Hello,

You need to ask your hosting provider if you have a SHA-2 SSL certificate. AbleCommerce doesn't make this requirement, but if Authorize.net needs your SSL certificate to meet SHA-2 standards, then you need to make sure you have an SSL certificate meeting these requirements.

Thanks,
Katie
Thank you for choosing AbleCommerce!

http://help.ablecommerce.com - product support
http://wiki.ablecommerce.com - developer support

jguengerich
Commodore (COMO)
Commodore (COMO)
Posts: 427
Joined: Tue May 07, 2013 1:59 pm

Re: AbleCommerce 7.0 webshop and Authorize.Net gateway update

Post by jguengerich » Tue Sep 01, 2015 9:02 am

Katie,

I think that means that Authorize.net's server will be switching to SHA-2. It sounds like AbleCommerce users can test with their Authorize.net "sandbox" account to make sure authorizations, purchases, etc. will still work.
Jay

BlackIce
Ensign (ENS)
Ensign (ENS)
Posts: 11
Joined: Mon Aug 31, 2015 1:16 am

Re: AbleCommerce 7.0 webshop and Authorize.Net gateway update

Post by BlackIce » Thu Feb 18, 2016 3:19 am

The following change can be cause compatibly issue with AbleCommerce 7.0?
It will be possible to receive Authorize.Net IDs (Transaction ID, Batch ID, etc.) that are not in sequential order. The limits of any Authorize.Net ID field should be no less than 20 characters.

Post Reply