Could not create SSL/TLS secure channel

For general questions and discussions specific to the AbleCommerce 7.0 Asp.Net product.
Post Reply
vadim
Ensign (ENS)
Ensign (ENS)
Posts: 14
Joined: Mon Apr 05, 2010 9:30 am

Could not create SSL/TLS secure channel

Post by vadim » Wed Mar 18, 2020 7:02 pm

Our website is having a problem with orders.
They are not going through.
Customers are seeing this error:

"There was a problem processing your payment: The request was aborted: Could not create SSL/TLS secure channel."

All payments are going through PayPal.
We had this issue 9 days ago.
I spoke with PayPAl support. They didn't change anything and all of a sudden it started to work.
But today this error popped up again. Nothing was changed on our side since last error.
People from Able don't answer my calls.
I have no idea where to seek for help!!!
Which side gives me that error? Mine (website) or PayPal side?

Please advice!

Thanks

User avatar
Naveed
Rear Admiral (RADM)
Rear Admiral (RADM)
Posts: 601
Joined: Thu Apr 03, 2008 4:48 am

Re: Could not create SSL/TLS secure channel

Post by Naveed » Thu Mar 19, 2020 1:06 am

Hi Vadim,

9 days is a lot of time. I am sorry for that if its an issue from our end.

Please tell me more about your website:

1. Version and build number.
2. Error details, and error log information.


Thanks,
Naveed Ashraf

User avatar
Naveed
Rear Admiral (RADM)
Rear Admiral (RADM)
Posts: 601
Joined: Thu Apr 03, 2008 4:48 am

Re: Could not create SSL/TLS secure channel

Post by Naveed » Thu Mar 19, 2020 1:10 am

Hi,

I have checked forums and figured that you had similar issues with PayPal in past (2015)

viewtopic.php?f=42&t=18540&p=81260#p81260

Please make sure its not the same problem with the SSL certificate or the root certificate(s) installed on the server.

Thanks,
Naveed Ashraf

vadim
Ensign (ENS)
Ensign (ENS)
Posts: 14
Joined: Mon Apr 05, 2010 9:30 am

Re: Could not create SSL/TLS secure channel

Post by vadim » Thu Mar 19, 2020 2:38 pm

Hi Naveed,

Domain :abc-machine-embroidery.com

In 2015 the problem was fixed by upgrading server OS.

My Able version:

AbleCommerce for ASP.NET
VERSION: 7.0.92.9476
Release Label: GoldR12SR2


Error log:

Provider threw exception in DoAuthorize.
Exception: The request was aborted: Could not create SSL/TLS secure channel.Stack Trace: at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context) at System.Net.HttpWebRequest.GetRequestStream() at CommerceBuilder.Payments.Providers.PayFlowPro.PaymentProvider.SendRequestToGateway(String requestData) at CommerceBuilder.Payments.Providers.PayFlowPro.PaymentProvider.DoAuthorize(AuthorizeTransactionRequest authorizeRequest) at CommerceBuilder.Services.PaymentService.

User avatar
Naveed
Rear Admiral (RADM)
Rear Admiral (RADM)
Posts: 601
Joined: Thu Apr 03, 2008 4:48 am

Re: Could not create SSL/TLS secure channel

Post by Naveed » Fri Mar 20, 2020 5:54 am

Hi,

It still seems a problem related to server OS and .net version installed on your system.


Here is some related information:
https://kevinchalet.com/2019/04/11/forc ... piling-it/
https://blogs.perficient.com/2016/04/28 ... t-support/

It seems that .net 4.6 need to be installed on the server, and also need to update Website/web.config file to use the updated .net runtime.

I am going to try it on local system and will get back to you with detailed instructions.

meanwhile please look into your Website/web.config file for something like:

<httpRuntime maxRequestLength="4096" requestValidationMode="2.0" targetFramework="4.6"/>

and let me know what is the value of "targetFramework"?

Thanks,

vadim
Ensign (ENS)
Ensign (ENS)
Posts: 14
Joined: Mon Apr 05, 2010 9:30 am

Re: Could not create SSL/TLS secure channel

Post by vadim » Fri Mar 20, 2020 1:33 pm

Hi,

I updated the line you've mentioned to "targetFramework="4.8" and repaired Framewok 4.8 on the server.

Looks like it started to work. Few orders went through

Thanks

I'll continue to watch this issue.

User avatar
Naveed
Rear Admiral (RADM)
Rear Admiral (RADM)
Posts: 601
Joined: Thu Apr 03, 2008 4:48 am

Re: Could not create SSL/TLS secure channel

Post by Naveed » Sat Mar 21, 2020 5:56 am

Hi,

That's great if it started to work.

Thanks for letting us know.

Thanks,
Naveed Ashraf

Post Reply