Upgrading from 5.5 to to 7 for PCI

This forum is dedicated to answering AbleCommerce 7.0 questions about PCI certification and compliance.
Post Reply
jdtaylor
Ensign (ENS)
Ensign (ENS)
Posts: 2
Joined: Tue May 11, 2010 1:35 pm

Upgrading from 5.5 to to 7 for PCI

Post by jdtaylor » Tue May 11, 2010 1:47 pm

We are currently looking to upgrade our AC 5.5 to AC 7. For AC 5.5, the CommerceBuilder5.dll that we have been using has had some customization and changes in the source code in order for it to work with our website. I download the demo however I was informed that the demo does not include the source code for the dll's. We wanted to compare the changes that we have done to the AC 5.5 dll with the AC 7 dll to see how long and how extensize it will be to upgrade from 5 to 7. Can anyone tell me if the source code for the AC 5.5 is similar or different from the AC 7 dll's or any other details about the dll that can help us determine how long it will take to upgrade to 7. Any help would be greatly appreciated it.

User avatar
Shopping Cart Admin
AbleCommerce Admin
AbleCommerce Admin
Posts: 3053
Joined: Mon Dec 01, 2003 8:41 pm
Location: Vancouver, WA
Contact:

Re: Upgrading from 5.5 to to 7 for PCI

Post by Shopping Cart Admin » Wed May 12, 2010 12:15 pm

Hello JD,

They are totally different. AbleCommerce 7.0 was a total re-write from the ground up in C#. I'd look at it another way, what are the customizations you've done, which might already be available in 7.0 and finally how long would it take to re-write the customizations.

What are the primary customizations that you've done to ac 5.5?

For additional information on the 7.0 API visit our wiki

http://wiki.ablecommerce.com/index.php/ ... uilder_API
Thanks for your support

Shopping Cart Guru
AbleCommerce.com
Follow us on Facebook

jdtaylor
Ensign (ENS)
Ensign (ENS)
Posts: 2
Joined: Tue May 11, 2010 1:35 pm

Re: Upgrading from 5.5 to to 7 for PCI

Post by jdtaylor » Thu May 13, 2010 6:54 am

Thank you for your response. I have a couple of more questions about this issue if you could answer as well. Would it be possible to just install the 7.0 DLLs and call the new Credit Authorization/Settlement functions from our code without going through an entire upgrade and if so, would we then be compliant from a PCI standpoint? Thanks.

User avatar
Michael Ward
AbleCommerce Moderator
AbleCommerce Moderator
Posts: 132
Joined: Thu Mar 03, 2005 3:00 am

Re: Upgrading from 5.5 to to 7 for PCI

Post by Michael Ward » Wed May 26, 2010 10:14 pm

Hello
Unfortunately no. The database table names and system calls are different than AC 5 from AC 7.
Thank you for your support

Michael Ward
Image.com
Follow us on Twitter http://twitter.com/AbleCommerce/

Post Reply