Avalara Bug

For general questions and discussions specific to the AbleCommerce GOLD ASP.Net shopping cart software.
Post Reply
User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Avalara Bug

Post by compunerdy » Wed Apr 15, 2020 1:49 pm

We just started using Avalara and we are having a issue where orders are 1 or 2 cents positive or negative. This makes the order show paid but stay in payment pending. We turned on the logs and tracked down the issue. Before order creation AC sends the header item only of kits and uses the total combined price for tax calculation. After the order is created/paid AC sends the individual items of the kit to Avalara and the rounding of each item's tax makes the total of the order off.

User avatar
Katie
AbleCommerce Admin
AbleCommerce Admin
Posts: 2645
Joined: Tue Dec 02, 2003 1:54 am
Contact:

Re: Avalara Bug

Post by Katie » Thu Apr 30, 2020 5:19 pm

This is not a bug in Avalara. Likely, what is happening is that you have itemized kits which essentially means that each product is treated separately in the order. In order to process a refund for a taxed item with Avalara, each product has its own tax calculation.

Trying to change the calculations at checkout would be difficult, but you could put your gateway in authorization mode and capture an adjusted amount. It sounds like it would only be off by a few cents. You might be able to use custom order statuses and a small custom change at checkout that could watch for cases when this happens and use authorization for those orders only.

Using itemized kits is an advanced feature of AbleCommerce, and I remember that we made it work according to their integration guide so refunds would process with the correct tax amount (calculated separately per item).

Hope this helps,
Katie
Thank you for choosing AbleCommerce!

http://help.ablecommerce.com - product support
http://wiki.ablecommerce.com - developer support

User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Re: Avalara Bug

Post by compunerdy » Fri May 01, 2020 11:35 am

I am sorry.. it is not a bug that your system using built in features does not work correctly?????????

During check out you send the main kit header price ONLY to Avalara for tax calculation
After they pay and you save the order you send each part INDIVIDUALLY to Avalara for tax calculation
So its if its not a Valara bug then its a AC bug..either way it should be fixed?

HOW IS THIS NOT A BUG!!!

I already paid for the newest version of AC but just have not had time to set it up. But if this is the kind of support I am going to get maybe I should look for a new program! I E-mailed Mike originally and he didn't even take the time to respond. Then weeks later I finally get someone to tell me its not a bug?

User avatar
Naveed
Rear Admiral (RADM)
Rear Admiral (RADM)
Posts: 607
Joined: Thu Apr 03, 2008 4:48 am

Re: Avalara Bug

Post by Naveed » Mon May 04, 2020 5:46 am

Hi,

Thank you for your patience.

I am trying to reproduce the issue with the Kit setup, if you please provide me more details with Kit and child products configurations. I hope I will be able to submit a fix or workaround to you.

Thanks.

User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Re: Avalara Bug

Post by compunerdy » Mon May 04, 2020 12:02 pm

This is the issue.. we verified this by looking at the avalara logs.

A kit (maybe only ones with hidden items) every time it is sent to Avalara uses the total price of the kit to ask for the tax calculation. But when the final order is created in the store AFTER paying each individual item in the kit is sent to Avalara so the tax calculation changes by a cent or two causing the system to not mark orders as paid, etc.

User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Re: Avalara Bug

Post by compunerdy » Tue May 05, 2020 3:21 pm

Is that clear enough or do you need more info?

User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Re: Avalara Bug

Post by compunerdy » Fri May 08, 2020 12:52 pm

Hello?

User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Re: Avalara Bug

Post by compunerdy » Wed May 13, 2020 11:45 am

Bueller.. Bueller

User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Re: Avalara Bug

Post by compunerdy » Wed May 20, 2020 2:35 pm

Wow.. top notch customer service here guys!

User avatar
compunerdy
Admiral (ADM)
Admiral (ADM)
Posts: 1273
Joined: Sun Nov 18, 2007 3:55 pm

Re: Avalara Bug

Post by compunerdy » Mon May 25, 2020 11:39 am

While there is still a bug with the Avalara implementation we did find a workaround. In Avalara they have a setting (not the default one) to calculate tax based on order totals rather than line items which seems to have fixed this issue.

Post Reply