Gold R11 - Strange behavor using SSL (Secure All Pages)

For general questions and discussions specific to the AbleCommerce GOLD ASP.Net shopping cart software.
Post Reply
Odettes
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 102
Joined: Wed Apr 02, 2008 11:00 am
Location: Stockholm, Sweden
Contact:

Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by Odettes » Tue Oct 13, 2015 10:46 pm

Hi!

I use a custom folder(I don't use App_Themes folder at all) in my root folder to store css, fonts and js files.
In my Layouts file I make a normal reference to my css file like this:

Code: Select all

<link href="/retail/css/style.css" rel="stylesheet" type="text/css" />
This work great in previous version of Gold, but with the new feature SSL "Secure All Pages" checked under /administration/Configure/Security/System Settings something goes wrong.

Instead of importing my css file it imports a generated text-file that looks like this:

Code: Select all

<html>
<head>
<title></title>
<!-- <script language="javascript">window.location.replace("http://beta.traileronline.se/retail/css/style.css");</script> -->
</head>
<body></body>
</html>
If I disable "Secure All Pages" it works like normal.

What to do?
Sincerely,
Thomas Berglund

https://traileronline.se
AbleCommerce Gold R11 Custom

User avatar
mazhar
Master Yoda
Master Yoda
Posts: 5082
Joined: Wed Jul 09, 2008 8:21 am
Contact:

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by mazhar » Wed Oct 14, 2015 1:44 am

What happens if you update the stylesheet include to have absolute URL with HTTPS in it? Like this

Code: Select all

<link href="https://beta.traileronline.se/retail/css/style.css" rel="stylesheet" type="text/css" />

User avatar
NC Software
AbleCommerce Partner
AbleCommerce Partner
Posts: 4620
Joined: Mon Sep 13, 2004 6:06 pm
Contact:

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by NC Software » Wed Oct 14, 2015 12:30 pm

Try a leading //
Neal Culiner
NC Software, Inc.

Odettes
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 102
Joined: Wed Apr 02, 2008 11:00 am
Location: Stockholm, Sweden
Contact:

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by Odettes » Thu Oct 15, 2015 1:33 am

mazhar wrote:What happens if you update the stylesheet include to have absolute URL with HTTPS in it? Like this

Code: Select all

<link href="https://beta.traileronline.se/retail/css/style.css" rel="stylesheet" type="text/css" />

Exact same result, something is wrong.
Sincerely,
Thomas Berglund

https://traileronline.se
AbleCommerce Gold R11 Custom

User avatar
Katie
AbleCommerce Admin
AbleCommerce Admin
Posts: 2645
Joined: Tue Dec 02, 2003 1:54 am
Contact:

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by Katie » Thu Oct 15, 2015 5:10 am

Did you also try Neal's suggestion? leading //
I use a custom folder(I don't use App_Themes folder at all) in my root folder to store css, fonts and js files.
I'm not sure why you decided to eliminate the App_Themes folder, but these are scenarios that we don't test during final QA. I would think that it should work though, especially with a fully qualified URL. Are you sure this isn't some other issue?
Thank you for choosing AbleCommerce!

http://help.ablecommerce.com - product support
http://wiki.ablecommerce.com - developer support

rmaweb
Commander (CMDR)
Commander (CMDR)
Posts: 118
Joined: Fri Sep 10, 2010 9:41 am

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by rmaweb » Thu Oct 15, 2015 7:55 am

In your style.css file that you are linking via https, are there any image, icon, font, etc links in that file? If so, are they being called with a //?

The // allows the browser to determine whether to load the file as http or https depending on the current situation.
Ryan A.
Scott's Bait and Tackle
http://store.scottsbt.com
Work In Progress
Able Gold R10
Bootstrap 3.3

Odettes
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 102
Joined: Wed Apr 02, 2008 11:00 am
Location: Stockholm, Sweden
Contact:

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by Odettes » Fri Oct 16, 2015 5:53 am

Katie wrote:Did you also try Neal's suggestion? leading //
I use a custom folder(I don't use App_Themes folder at all) in my root folder to store css, fonts and js files.
I'm not sure why you decided to eliminate the App_Themes folder, but these are scenarios that we don't test during final QA. I would think that it should work though, especially with a fully qualified URL. Are you sure this isn't some other issue?
Yes, I tried that to.
If I enable SSL but skipp "Secure All Pages" it works fine so it looks like the problem is there.
Sincerely,
Thomas Berglund

https://traileronline.se
AbleCommerce Gold R11 Custom

Odettes
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 102
Joined: Wed Apr 02, 2008 11:00 am
Location: Stockholm, Sweden
Contact:

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by Odettes » Wed Oct 21, 2015 9:36 am

Any idea what to do?
Sincerely,
Thomas Berglund

https://traileronline.se
AbleCommerce Gold R11 Custom

User avatar
mazhar
Master Yoda
Master Yoda
Posts: 5082
Joined: Wed Jul 09, 2008 8:21 am
Contact:

Re: Gold R11 - Strange behavor using SSL (Secure All Pages)

Post by mazhar » Thu Oct 22, 2015 6:36 am

Odettes wrote:Any idea what to do?
Try adding your custom directory containing CSS in SSL.config under secure pages node like this

Code: Select all

<directory path="your_css_directory_name_here" />
and try again.

Post Reply