Error Messages on Http vs. HttpS

For general questions and discussions specific to the AbleCommerce GOLD ASP.Net shopping cart software.
Post Reply
ChipWV
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 87
Joined: Tue Feb 03, 2009 12:51 pm

Error Messages on Http vs. HttpS

Post by ChipWV » Fri Apr 21, 2017 9:44 am

We're getting these types of errors:
An error has occured at http://www.ovisonline.com/
Exception: Object reference not set to an instance of an object. Stack Trace: at CommerceBuilder.Users.UserRepository.LoadForUserName(String userName, Boolean createMissing) at CommerceBuilder.Users.UserDataSource.LoadForUserName(String userName, Boolean createMissing) at CommerceBuilder.Services.Membership.WebUserLocator.Locate() at CommerceBuilder.Common.AbleContext.get_User() at CommerceBuilder.Services.PageTracker.Track(HttpApplication application, HttpContext context) at CommerceBuilder.Services.HttpModule.a(Object A_0, EventArgs A_1) at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
It also happens with http://ovisonline.com/ http://www.ovisonline.com/grooved http://www.ovisonline.com/Hettich.asp and similar. The error doesn't happen every time, so hard to define what is really going on. Other than that the whole site SSL is just fine.

Thanks in advance,
Chip

eileen
Lieutenant, Jr. Grade (LT JG)
Lieutenant, Jr. Grade (LT JG)
Posts: 40
Joined: Sun Feb 11, 2007 10:59 pm
Location: Novato, CA
Contact:

Re: Error Messages on Http vs. HttpS

Post by eileen » Mon May 01, 2017 10:37 am

We have reported the same error. See this post:
Server error - url without www prefix
viewtopic.php?f=65&t=18978.
The error still occurs intermittently. At one point we were able to consistently reproduce the error using https:// when we switched between demo and live mode. The error consistently occurred in demo mode, but consistently did appear in live mode. Then the problem became inconsistent again, so we could not report it as a bug. Our developers and ISP seem to agree that the problem is within the source code (see the other forum thread above), but the folks at AbleCommerce have not been able to reproduce it.

ChipWV
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 87
Joined: Tue Feb 03, 2009 12:51 pm

Re: Error Messages on Http vs. HttpS

Post by ChipWV » Tue May 09, 2017 7:23 am

I'm figuring out more of where this is happening. If I have a fixed redirect setup, it throws the general error. For example a redirected directory, word or inbound link or whatever, called sample:

http://www.domain.com/sample will not go to https://www.domain.com/sample
You get /Errors/GeneralError.aspx?aspxerrorpath=/sample

I think I have IIS setup correctly to redirect http://www.domain.com to https://www.domain.com However, could the AC application be doing a redirect before IIS has a chance to do its redirect?

I think the error is being thrown by AC because (and I’m guessing here) that it wasn’t setup to handle the http to httpS redirect at the same time as another static (and probably dynamic) redirect.

ChipWV
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 87
Joined: Tue Feb 03, 2009 12:51 pm

Re: Error Messages on Http vs. HttpS

Post by ChipWV » Tue May 09, 2017 8:57 am

More information:

I seem to have narrowed down the problem. It seems AC is not following what is in the "Custom Extensions" for redirects. All redirects ending in aspx work fine, however I have allowed htm, html, and asp extensions, as well as, checked the box for URLs without an extension. Also, the URL tesing tool does show that the test is valid for redirects that don't actually work in production with httpS

Any bug fix for this?

Thanks,
Chip
Attachments
URL-rules-test.JPG
(40.72 KiB) Downloaded 6426 times
URL-rules.JPG
(34.47 KiB) Downloaded 6433 times

ChipWV
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 87
Joined: Tue Feb 03, 2009 12:51 pm

Re: Error Messages on Http vs. HttpS

Post by ChipWV » Fri May 19, 2017 9:57 am

10 days and no response to this or the bug report I sent. Is everybody on vacation?

User avatar
Katie
AbleCommerce Admin
AbleCommerce Admin
Posts: 2649
Joined: Tue Dec 02, 2003 1:54 am
Contact:

Re: Error Messages on Http vs. HttpS

Post by Katie » Sat May 20, 2017 12:40 am

Hello Chip,

It looks like you are on the latest version of AbleCommerce, so why would you be experiencing issues that we fixed in a patch for Gold R11?

Check this out - http://help.ablecommerce.com/index.htm# ... ld_r11.htm

Was this install upgraded recently?

Thanks
Katie

ps. No vacation...just super busy this time of year.
Thank you for choosing AbleCommerce!

http://help.ablecommerce.com - product support
http://wiki.ablecommerce.com - developer support

ChipWV
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 87
Joined: Tue Feb 03, 2009 12:51 pm

Re: Error Messages on Http vs. HttpS

Post by ChipWV » Mon May 22, 2017 7:56 am

Hi Katie,

Yes, upgraded in February. I've currently got the error page redirected to the home page, by my CDN, so that those clicks go somewhere useful, but if you like I can temporarily turn that off for testing.

Here's a list of the installed versions:

Code: Select all

AbleCommerce for ASP.NET
VERSION: 7.0.92.9266
Release Label: GoldR12SR1
DATABASE: NHibernate.Dialect.MsSql2005Dialect
.NET CLR v4.0.30319.1026
ASP.NET TRUST: Unrestricted

AjaxControlToolkit: 4.1.51116.0
AntiXssLibrary: 4.0.0.0
Castle.Core: 2.5.1.0
Castle.Windsor: 2.5.1.0
CommerceBuilder: 7.92.6081.12193
CommerceBuilder.AcTestProvider: 7.89.5365.28134
CommerceBuilder.Amazon: 7.91.5742.35316
CommerceBuilder.AustraliaPost: 7.89.5365.28134
CommerceBuilder.AuthorizeNet: 7.92.6081.35353
CommerceBuilder.AuthorizeNetCIM: 7.92.6059.30775
CommerceBuilder.AvaTax: 7.91.5742.35327
CommerceBuilder.BankOfCanada: 7.91.5742.35330
CommerceBuilder.CanadaPost: 7.89.5365.28135
CommerceBuilder.CyberSource: 7.92.5959.27685
CommerceBuilder.DHLInternational: 7.89.5365.28135
CommerceBuilder.ECB: 7.89.5365.28135
CommerceBuilder.EPaymentIntegrator: 7.92.5969.31585
CommerceBuilder.GoogleCheckout: 7.89.5365.28138
CommerceBuilder.InternetSecure: 7.91.5742.35337
CommerceBuilder.Licensing: 7.92.6081.12203
CommerceBuilder.LinkPoint: 7.91.5742.35338
CommerceBuilder.Paradata: 7.89.5365.28136
CommerceBuilder.PayFlowPro: 7.89.5365.28136
CommerceBuilder.PayJunction: 7.91.5742.35343
CommerceBuilder.PaymentechOrbital: 7.92.5959.27691
CommerceBuilder.PayPal: 7.92.6081.35358
CommerceBuilder.Protx: 7.91.5742.35353
CommerceBuilder.SkipJack: 7.91.5742.35358
CommerceBuilder.TaxCloud: 7.92.5959.27694
CommerceBuilder.UI: 7.92.6081.12204
CommerceBuilder.UPS: 7.91.5742.35366
CommerceBuilder.USPS: 7.92.5959.27697
CommerceBuilder.Utility.Csv: 8.0.0.0
CommerceBuilder.WATax: 7.91.5742.35368
CommerceBuilder.WebApi: 7.92.6081.12206
CyberSource.Base: 2.0.0.0
CyberSource.Clients: 5.0.2.0
CyberSource.Clients.XmlSerializers: 5.0.2.0
CyberSource.WSSecurity: 2.0.0.0
CybsWSSecurityIOP: 1.0.0.0
HtmlSanitizationLibrary: 4.0.0.0
ICSharpCode.SharpZipLib: 0.86.0.518
Iesi.Collections: 1.0.1.0
log4net: 1.2.10.0
Lucene.Net: 2.9.4.2
Microsoft.Data.Edm: 5.1.0.0
Microsoft.Data.OData: 5.1.0.0
Microsoft.Data.OData.Contrib: 5.1.0.0
Microsoft.Web.Infrastructure: 1.0.0.0
Microsoft.Web.Mvc: 2.0.0.0
MvcContrib: 2.0.95.0
Newtonsoft.Json: 4.5.0.0
NHibernate: 3.3.1.4000
NHibernate.ByteCode.Castle: 3.1.0.4000
NHibernate.Caches.SysCache: 3.3.3.4000
NHibernate.Search: 2.0.2.4000
nsoftware.InPayWeb: 6.0.5849.0
NVelocity: 7.2.0.0
PaygatewayNET: 3.0.0.0
PayPalCoreSDK: 1.7.0.0
PayPalMerchantSDK: 2.16.117.0
SanitizerProviders: 1.0.0.0
System.Net.Http: 2.0.0.0
System.Net.Http.Formatting: 4.0.0.0
System.Spatial: 5.1.0.0
System.Web.Http: 4.0.0.0
System.Web.Http.OData: 0.2.0.0
System.Web.Http.WebHost: 4.0.0.0
System.Web.Mvc: 4.0.0.0
System.Web.Razor: 2.0.0.0
System.Web.WebPages: 2.0.0.0
System.Web.WebPages.Deployment: 2.0.0.0
System.Web.WebPages.Razor: 2.0.0.0
wwHoverPanel: 1.85.0.0

User avatar
Katie
AbleCommerce Admin
AbleCommerce Admin
Posts: 2649
Joined: Tue Dec 02, 2003 1:54 am
Contact:

Re: Error Messages on Http vs. HttpS

Post by Katie » Wed May 24, 2017 12:20 pm

I think I have IIS setup correctly to redirect http://www.domain.com to https://www.domain.com However, could the AC application be doing a redirect before IIS has a chance to do its redirect?
I missed this info from one of your previous posts. AbleCommerce should handle the redirect from non-ssl to ssl, so you shouldn't need anything setup in IIS.
Thank you for choosing AbleCommerce!

http://help.ablecommerce.com - product support
http://wiki.ablecommerce.com - developer support

ChipWV
Lieutenant Commander (LCDR)
Lieutenant Commander (LCDR)
Posts: 87
Joined: Tue Feb 03, 2009 12:51 pm

Re: Error Messages on Http vs. HttpS

Post by ChipWV » Fri May 26, 2017 10:00 am

I mis-spoke, Able is handling all the HttpS redirects.

Thanks, have a great Memorial Day weekend!

Chip

Post Reply